Résoudre un problème lié à libGL avec Qt5 sous Ubuntu 14.10

À la première tentative de compilation d’un programme avec Qt5 sous Ubuntu 14.10, j’obtenais une erreur liée à la librairie libGL :

ld: cannot find -lGL

Après quelques recherches, il semble que la librairie cherchée provienne du paquet

libglu1-mesa-dev.

Ce dernier était installé par défaut sur Ubuntu, mais Qt5 n’allait pas chercher dans le bon répertoire, du coup j’ai créé un lien symbolique pour que tout rentre dans l’ordre. Se placer dans le répertoire /usr/lib/x86_64-linux-gnu puis lancer :

sudo ln -s mesa/libGL.so.10.1.1.28614 libGL.so

(à adapter à la version de libGL qui est présente sur votre système).

Laissez un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *